[squeakland] Etoys scripting broken on Mac OS X Leopard: drag and drop into script holder script?

Yoshiki Ohshima yoshiki at vpri.org
Thu May 8 23:06:26 PDT 2008


> Since a few months I can not create tile scripts in Etoys anymore. I  
> can drag a tile from a viewer and drop it anywhere and a new script  
> holder appears around my dropped tile. But when I drag a second tile  
> (script phrase) from the viewer and hover over the script holder no  
> insertion point appears.

  The second tile wasn't a variable reference, yes?  If it was, the
scriptor wouldn't take it as it is not a command or assignment.  If
your first tile and the second tiles are the "forward by" command
tiles, what happens?

  And, when you say a new script holder, that is the one with yellow
exclamation mark button and script name and, etc. where you edit the
script, yes?  Let us call it a script editor.  (In the later version
of OLPC Etoys, we introduced a different thing called
ScriptingTileHolder that wraps a naked tile.)

> When I drop the tile on top of the script holder it does not get  
> embedded but becomes a seperate tile on the background/desktop.
> No attempt to put it into the script holder works,

  Unless you get the green drop zone, the script editor won't accept
the dropped tile.

> When I use the halo I can see that the script holder does excepts  
> drops.The second tile could also gets no new script holder around it,  
> no mater where I drop it,

  How did you check if the "script holder expects (?) drops"?

> I tried it on the Squeakland (browser plugin) (version 3.0), I  
> downloaded the XO image and also tried it on a regular squeak 3.9  
> image but nowhere do I get it to work.

  What do you mean by "download the XO image and also tried
it on a regular squeak 3.9 image"?  You tried it on the XO image and
Squeak 3.9 image?

> I use Mac OS X Leopard on a fast G5 Quad so maybe therein lies the  
> problem?
> It took me a few months to post this because I thought it had  
> something to do with my Universel Access settings on Leopard that was  
> interfering with drag and drop elsewhere in Mac OS X like the finder.  
> But no, I have reinstalled a clean Leopard and the problem still exists.

  Etoys' UI is completely independent from the platform.  

> This effectively makes Etoys (and Kedama) unusable so I think it  
> should be resolved.
> Where to look for a solution?
> Has anybody heard about this problem before?

  From your description, it is very hard to see what was actually
going on, but I would think that there is some simpler
misunderstanding like trying to drop a value reference onto the place
where the script editor expects a command or an assignment.

  You don't have to try different images or such.  In whatever image,
please explain us what you exactly did.

-- Yoshiki

More information about the Squeakland mailing list