[squeakland] Etoys scripting broken on Mac OS X Leopard: drag and drop into script holder script?

Merik Voswinkel merik at mac.com
Thu May 8 01:35:14 PDT 2008

Since a few months I can not create tile scripts in Etoys anymore. I  
can drag a tile from a viewer and drop it anywhere and a new script  
holder appears around my dropped tile. But when I drag a second tile  
(script phrase) from the viewer and hover over the script holder no  
insertion point appears.
When I drop the tile on top of the script holder it does not get  
embedded but becomes a seperate tile on the background/desktop.
No attempt to put it into the script holder works,

When I use the halo I can see that the script holder does excepts  
drops.The second tile could also gets no new script holder around it,  
no mater where I drop it,

I tried it on the Squeakland (browser plugin) (version 3.0), I  
downloaded the XO image and also tried it on a regular squeak 3.9  
image but nowhere do I get it to work.

I use Mac OS X Leopard on a fast G5 Quad so maybe therein lies the  

It took me a few months to post this because I thought it had  
something to do with my Universel Access settings on Leopard that was  
interfering with drag and drop elsewhere in Mac OS X like the finder.  
But no, I have reinstalled a clean Leopard and the problem still exists.

This effectively makes Etoys (and Kedama) unusable so I think it  
should be resolved.
Where to look for a solution?
Has anybody heard about this problem before?


More information about the Squeakland mailing list