[Squeakland] Re: [Etoys] A new experimental version of OLPC image for non-XO environments

Yoshiki Ohshima yoshiki at vpri.org
Fri Feb 22 16:25:04 PST 2008


At Tue, 19 Feb 2008 12:54:50 +0530,
K. K. Subramaniam wrote:
> 
> On Monday 18 February 2008 12:00:11 pm Yoshiki Ohshima wrote:
> >   Hello,
> >
> >   While ago, we made an experimental version of Etoys image based on
> > the OLPC code base but for non-XO environments.  We made another
> > iteration of it and upload it to:
> >
> > http://tinlizzie.org/olpc/OLPC-Etoys080211.zip
> The 3.9-12/squeak binary gives me a "Floating point exception" error on Debian 
> (Etch). A trace showed the fault occuring while loading libc.so.6. Is the 
> code compiled to work only for a specific version of libc6?
> 
> VM 3.9-8 (from Squeak-3.9-8.i686-pc-linux-gnu.tar.gz) works fine on the same 
> box.
> 
> Anyone else face this error?

  Subbu.  Sorry, you reported it once before but I just put some
wishful thinking and the problem goes away; so it still happens.

  A few enhancement since 3.9-8 is nice to have.  If the problem is
only libc, we might be able to have different versions compiled
differently, but this is something we would like to avoid.  Hmm.

-- Yoshiki



More information about the Squeakland mailing list