[Squeakland] Mozilla Plugin and Debian (Linux)

Bert Freudenberg bert at squeakland.de
Fri Jan 28 18:47:30 PST 2005

You have the wrong image, which appears to be the normal developer 
image requiring a changes and a sources file. The image to be used with 
the plugin does not need either. Download this:


Unzip, and move the image into your .npsqueak directory. Now everything 
should be fine.

To install that image for every user, copy it to /usr/lib/squeak using 
the name that npsqueakrun expects.

You also might try to zap everything and install from the updated 
sources Jens sent you off-list, or from his RPMs (use "alien" to 
convert them to debs).

- Bert -

Am 26.01.2005 um 17:36 schrieb JP Glutting:

> Ok. I have a .npsqueak directory, with two empty directories in it:
> secure/ and untrusted/, so it looks like the process got strated and
> stopped at  some point.
> The file /usr/lib/squeak/3.6-3/npsqueak.so calls
> /usr/lib/squeak/3.6-3/npsqueakrun, which I do have, so that seems to
> be fine.
> When I run npsqueakrun by hand, it says it can't find
> /usr/lib/squeak/squeak.image, which is because I don't have one. I do
> have squeak.image.gz, which is a symlink to Squeak3.6-5429.image.gz.
> Can squeak use compressed images? Should it try?
> I am going to try unzipping it and symlinking the result...
> Well, that was not so great. It complained that it could not find
> /usr/lib/squeak/3.6-3/SqueakV3.sources (which it didn't, because the
> sources file is in /usr/lib/squeak, one directory up), and then opened
> the whole Squeak desktop in the browser.
> Now I symlink SqueakV3.sources from the 3.6-3 sub-directory:
> Nope, now it complains that it cannot locate SqueakPlugin.changes. I
> can't locate it either, so I am oging to call it quits. I have the
> flu, so when I am feeling a little better, I am just going to purge
> all the squeak .debs and try again with version 3.7.5-beta.
> Thanks again for all the help!
> JP
> On Wed, 26 Jan 2005 00:23:46 +0100, Bert Freudenberg 
> <bert at squeakland.de> wrote:
>> Am 25.01.2005 um 16:33 schrieb JP Glutting:
>>> I am still trying to get the Squeak plugin to work in Debian. I have
>>> version 3.6-3 installed (from .debs), and the desktop environment
>>> works fine.
>>> I downloaded a npsqueak-image installer, and went through the install
>>> script to find out what to do. It seems that there is a script in
>>> /usr/lib/squeak called npsqueakregister that needs to be run. (the
>>> install script actually was looking in /usr/local/lib/, but the .debs
>>> put squeak in /usr/lib, which should be fine).
>>> The npsqueakregister script looks for
>>> /usr/lib/squeak/3.6-3/npsqueak.so, which I have.
>>> The script, when run, gives this message:
>>> File not found: /usr/lib/squeak/3.6-3/npsqueak.so
>>> Aborting.
>>> It seems that the permissions on npsqueak.so are not set correctly. 
>>> It
>>> is set with permissions 644 [rw-r--r--], when the file needs to be
>>> executable. The npsqueakregister script is actually checking to see 
>>> if
>>> npsqueak.so is an executable file (if [ ! -x "$NPSQUEAK_SO" ] ), and
>>> exits with an error message if it is not.
>>> I changed the permissions on npsqueak.so [chmod a+x npqueak.so]
>>> The npsqueakregister script then produces:
>>> Registering /usr/lib/mozilla/plugins/npsqueak.so
>>> create symbolic link `/usr/lib/mozilla/plugins/npsqueak.so' to
>>> `/usr/lib/squeak/3.6-3/npsqueak.so'
>>> Registering /usr/lib/mozilla-firefox/plugins/npsqueak.so
>>> create symbolic link `/usr/lib/mozilla-firefox/plugins/npsqueak.so' 
>>> to
>>> `/usr/lib/squeak/3.6-3/npsqueak.so'
>>> Registering /usr/lib/mozilla-snapshot/plugins/npsqueak.so
>>> create symbolic link `/usr/lib/mozilla-snapshot/plugins/npsqueak.so'
>>> to `/usr/lib/squeak/3.6-3/npsqueak.so'
>>> Which looks great. However, I still can't run any .pr files in the
>>> browser. I just get a blank, white page, with the message "Done" in
>>> the status bar. This is what happened with OS X when the plugin was
>>> not working as well.
>>> On the positive side, Squeak is registered as a plugin (it registers
>>> sts, sqo and pr files, while OS X only only registers sts and pr
>>> files).
>> Rejoice, you're almost there :-)
>>> I am going to keep twiddling with this, and try to figure out what
>>> went wrong. Any suggestions welcome.
>> So the plugin is loaded, it now tries to start the VM with image file.
>> After you tried to load a project in the browser, did the .npsqueak
>> directory in your home get created? If yes, then the npsqueak.so 
>> plugin
>> succesfully executed the npsqueakrun script in
>> /usr/lib/squeak/<version>. If not, make sure that file exists (you
>> might want to look into the npsqueak.so binary for which script it
>> actually tries to execute using
>>         strings npsqueak.so | grep npsqueakrun
>> The script creates some directories in $HOME/.npsqueak and copies the
>> plugin image file from /usr/lib/squeak. After that, it executes the
>> regular Squeak VM with the image copy, but redirects the main window
>> into the browser page.
>> You might try a newer VM (3.7b-5 from http://squeak.hpl.hp.com/unix/)
>> and the current image
>> (http://squeakland.org/installers/SqueakPlugin.image.zip, extract that
>> into ~/.npsqueak/).
>> I'm cc'ing Jens Lincke who is currently updating the Squeakland Linux
>> packages (the download at squeakland is rather dated). We fixed a few
>> oddities and might even have some shiny new debs for you :-) Also 
>> cc'ed
>> is Ian so he knows what's going on.
>> - Bert -
> -- 
> "It is difficult to get a man to understand something when his salary
> depends upon his not understanding it." - Upton Sinclair

More information about the Squeakland mailing list