[Etoys-notify] [JIRA] Updated: (SQ-106) Make Monticello load and work in etoys image

jira at immuexa.com jira at immuexa.com
Sat May 30 21:55:37 EDT 2009

     [ http://tracker.immuexa.com/browse/SQ-106?page=all ]

Scott Wallace updated SQ-106:

    Fix Version: squeakfest 2009 release - desirables
                     (was: squeakfest 2009 release - possibles)

> Make Monticello load and work in etoys image
> --------------------------------------------
>          Key: SQ-106
>          URL: http://tracker.immuexa.com/browse/SQ-106
>      Project: squeakland
>         Type: Feature
>   Components: etoys
>     Reporter: team
>     Priority: Eventual
>      Fix For: squeakfest 2009 release - desirables

> Derived from TRAC ticket #8327 (karl ramberg, sept 2008), "Monticello loading fails"
> Without some fiddling, evidently at present no version of Monticello will load directly into an etoys dev image without incident.   It would be good to have a version of Monticello which coud be effortlessly loaded into such an image.
> ----
> Pasted below is the log discussion in sept 08 on the TRAC ticket referenced:
> (karl) Loading Monticello into the Etoys image fails :-(
> (bert) Can you be more specific? What exactly are you trying to do?
> (karl) Initializing MCWorkingCopy fails with a "Dictionary key not found" at the end of loading Monticello.
> (bert) Which Monticello version are you trying to load? This looks very much like a Monticello bug, not an Etoys bug.
> (karl) It fails on every version of Monticello I have tried. Have anyone succeeded in loaded Monticello into the image lately? Which version did they use ?
> (bert) See e.g. http://wiki.laptop.org/go/Etoys_Tips_and_Tricks (and LPF could certainly be made to work).
> (kar) The issue is with class MczInstaller and goes away when you zap it's Versions class var. You loose all the prior installed stuff tho by doing this.
> (bert) Well, if you have a fix for that ...
> (karl) Well the quick fix is to execute
> MczInstaller clearVersionInfo
> A better fix would be to understand why converting the MczInstaller version info to Monticello is failing, I tried to understand and failed...
> I'll mark this bugreport as Opportunity
> Maybe the etoys-dev image could have a small errata for stuff like this, easing the initial adoptation ?
> (bert) Oh, the Monticello fix is simple, it just needs to protect against missing version info fields. When I load Monticello I usually just fix the method on the fly when the debugger comes up ;)
> (karl) Ah, can you upload a version marked as Etoy image compatible ?

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

More information about the Etoys-notify mailing list