[etoys-dev] Problem installing Etoys-To-Go on Ubuntu Server 11.10

Bert Freudenberg bert at freudenbergs.de
Mon Oct 17 05:27:46 EDT 2011

On 16.10.2011, at 00:42, Steve Thomas wrote:

> When I downloaded Etoys To Go from squeakland and tried to run it didn't work.   This was because uname -m returned x86_64 but the only directory for Linux was i686
> Made the simple change shown below and it worked fine.
> #!/bin/bash
> # File:        etoys.sh (Etoys-To-Go version)
> # Author:      Bert Freudenberg
> # Description: Script to run etoys.image on the Squeak VM binary,
> #              using default directories relative to the installation itself
> APP=`dirname "$0"`
> APP=`cd "$APP";pwd`
> TOP=`dirname "$APP"`
> OS=`uname -s`
> #CPU=`uname -m`
> CPU="i686"
> BIN="$APP/Contents/$OS-$CPU"
> VM="$BIN/etoys"
> Not sure if we can simply change to check if Linux and skip the CPU naming issues, but it worked in this case.

The code in the repository has this:

CPU=`uname -m`
[ -d "$BIN" ] || BIN="$APP/Contents/Linux-i686"

So it should fall back to Linux-i686 in all unknown cases.

> Also when I tried to install Etoys from Ubuntu software Center it installed 3.0 from Ubuntu 10.x and 4.0 from 11.10.

Yep. It appears the maintainers only package new Etoys versions for newer OS versions. It would extra effort to test new versions on older OSes. I'm not even sure who packages Etoys for Ubuntu these days. It might still trickle down from Debian, which is semi-automatic. But to get older versions updated would need some manual intervention.

- Bert -

-------------- n?chster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.squeakland.org/pipermail/etoys-dev/attachments/20111017/cb2be652/attachment.html>

More information about the etoys-dev mailing list