[etoys-dev] Problem installing Etoys-To-Go on Ubuntu Server 11.10

Steve Thomas sthomas1 at gosargon.com
Sat Oct 15 18:42:19 EDT 2011

When I downloaded Etoys To Go from squeakland and tried to run it didn't
work.   This was because *uname -m* returned *x86_64* but the only directory
for Linux was *i686*
Made the simple change shown below and it worked fine.

# File:        etoys.sh (Etoys-To-Go version)
# Author:      Bert Freudenberg
# Description: Script to run etoys.image on the Squeak VM binary,
#              using default directories relative to the installation itself

APP=`dirname "$0"`
APP=`cd "$APP";pwd`
TOP=`dirname "$APP"`
OS=`uname -s`
#CPU=`uname -m`

Not sure if we can simply change to check if Linux and skip the CPU naming
issues, but it worked in this case.

Also when I tried to install Etoys from Ubuntu software Center it installed
3.0 from Ubuntu 10.x and 4.0 from 11.10.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakland.org/pipermail/etoys-dev/attachments/20111015/ffc2d778/attachment.html>

More information about the etoys-dev mailing list