[etoys-dev] Camera in e-toys/scratch

Derek O'Connell doc at doconnel.f9.co.uk
Thu Oct 6 13:13:58 EDT 2011

Hi Gonzalo, Bert,

I took a quick look at Scratch on XO-1.5 (Build: 5 customised, Sugar: 
0.93.4, Fw: Q3B19) and saw the effect mentioned in ticket/11297. At 
first guess this looks like a conversion problem in libv4l2 (new 
version?), confirmed by copying my desktop versions of libv4l2.so.0 and 
libv4lconvert.so.0 to the XO and then the camera image was perfect 
(although frame-rate was a little on the slow side). So this problem 
possibly needs bouncing elsewhere.

Re supporting etoys/other-platforms, the c-code [1], image code [2] and 
example morph [3] was released ~20 months ago so I have no idea why it 
was not adopted. I do know it worked in etoys earlier this year since I 
loaded it all up to do a 3D side-by-side demo using two webcams.

[2] http://www.squeaksource.com/CameraPlugin.html
[3] http://www.squeaksource.com/WebCamMorph.html

Btw, I don't know what the "scratch-activity" script is trying to do by 
attempting to copy /usr/bin/squeak to the activities "bin" dir but it fails.


On 06/10/11 09:53, Bert Freudenberg wrote:
>  On 05.10.2011, at 22:15, Gonzalo Odiard wrote:
> > After checking the plugins in Scratch, I have tried to use the
> > camera in e-toys and.. is not working :( There are a old bug about
> > this http://dev.laptop.org/ticket/9813 but never was resolved. Is
> > possible use the scratch plugin in e-toys? Or use part of the
> > code?
>  Certainly. It would have the additional benefit of working on other
>  platforms than Linux, so we'd love to have that.
>  I think it was even on someone's to-do list. However, I don't think
>  anyone's working on it right now.
> > The scratch camera plugin is working very well in xo-1.75 and no
> > so good in xo-1.5 (http://dev.laptop.org/ticket/11297)
> >
> > Gonzalo
>  - Bert -

More information about the etoys-dev mailing list