[etoys-dev] QuickGuide title translations
bert at freudenbergs.de
Mon May 31 05:20:18 EDT 2010
On 31.05.2010, at 11:15, Korakurider wrote:
> On Mon, May 31, 2010 at 5:58 PM, Bert Freudenberg <bert at freudenbergs.de> wrote:
>> On 28.05.2010, at 10:40, commits at source.squeak.org wrote:
>>> A new version of Morphic was added to project Etoys Inbox:
>>> ==================== Summary ====================
>>> Name: Morphic-KR.10
>>> Author: KR
>>> Time: 28 May 2010, 7:39:39 pm
>>> UUID: c4bb977a-6bad-dd4b-a669-d041488cc16a
>>> Ancestors: Morphic-KR.9
>>> For SQ-562:
>>> Introduce catalog for QuickGuides to translate display of index and control display order.
>>> + the catalog file "catalog.txt" is placed to where QG contents reside
>>> Format is like this:
>>> :NavBar/Navigator <--- categoryName/title of category
>>> PaintBrushes/Brushes <--- guideName/title of guide
>>> PaintColorPalette/Color Palette
>>> Order of guides in some category can be specified in this file.
>>> Titles for categories and guides can be translated.
>>> The file has to be UTF8 encoded.
>>> File name for each guide contents is assumed as <guideName>.sexp.data.gz.
>>> <guideName> should be named only with ascii characters
>>> for portability among various filename encodings.
>> That's a very good solution for translating the QuickGuide names I think!
> Thanks for your comment !
>> Feel free to commit to the main repository.
> I will, with changes you proposed...
>> One change I would make is call it "index.txt" instead, because I think elsewhere we refer to the top page as index page.
> I wanted to call it "index" but finally named "catalog" because
> there is "index page" of QuickGuides.
> I am willing to change it if you don't feel confusing :-)
Well, this file basically defines the index page, right? So calling it index would seem less confusing to me.
Or am I confused already? ;)
- Bert -
>> Also, I personally would prefer "|" as separator between name and title, "/" to me looks like a path separator. But maybe I'm just >too used to unix path names ;)
> I also think "|" is better than "/" as someone might want to use /
> in title itself.
>> - Bert -
More information about the etoys-dev