[etoys-dev] Re: Committing to etoys main repo

Bert Freudenberg bert at freudenbergs.de
Tue May 25 06:37:33 EDT 2010

(I'm answering this on-list)

On 25.05.2010, at 01:35, Ricardo Moran wrote:
> I tried to update my image and I got an emergency evaluator. I was about to report the issue when I realized my image was the problem, other images updated just fine. Anyway, I managed to update correctly (I think) by changing the "GetText-Localization" category to "System-Localization". I'm not sure why that worked, though.

What happened is that this update:


loaded GetText-bf.2 before System-bf.16. This would be the right order if you had not had GetText-Richo.1 in your image yet (as when you update a clean image). But since I moved back stuff from GetText to System, loading GetText first actually removed a few essential classes from your image (they would have been added back when loading System, but it failed before).

Moving classes and methods between packages is delicate in Monticello. With a series of package configurations it can be made to work fine. E.g., compare how these configs differ in the order of GetText and System packages: 


In update #2375 I combined these two configs into one, which worked in a clean image. I now think that was a mistake - had I made a changeset with these two configs it should have worked fine even in your image. Lesson learned.

A better way would be to load those packages together rather than sequentially, but our current Monticello version does not support that. Also, the sequential loading at least is predictable ...

> Just to be sure, the latest version is 'etoys4.1 of 29 April 2010 update 2378 (repo v1117 of 24 May 2010)', right?


And welcome as an Etoys developer - you have commit access to the main repo now! :)

- Bert -

More information about the etoys-dev mailing list