[etoys-dev] Re: [squeak-dev] Re: Brand new Ubuntu experience with etoys

Bert Freudenberg bert at freudenbergs.de
Thu May 13 00:24:56 EDT 2010

Am 12.05.2010 um 19:41 schrieb Jerome Peace:
> Hi Bert,
>  Thanks again for your help.
> The lastest version of the error message is a good improvement over the first too. Good.
> I did some more delving into the Ubuntu Software Center. 
> Etoys and Dr. Geo. show up in the educational category.
> There are also five squeak entries in the development category.
> A repeat of the vm entry, the 3.9 images and changes, the V3 sources, the V39 sources and one for the squeak-plugin-image (a 3.8 based image)
> The last entry only offers the image and changes file not the connecting link.
> My current efforts are changing from reporting my experience to solving the problem I want solved. Namely getting the plugin to work so I can launch showcase stuff into my browser.
> I have downloaded Etoys-2-Go. 
> A filecheck shows that it contains the npetoys.so module. A further check shows thats the only one in the entire file system. So the etoys that Ubuntu installs is definitely lacking that module.
> So what would be a good way to hook Etoys-2-go into a browser, Firefox in particular at the moment?
> I am also curious if it might be useful to copy the module in Etoys-2-go into the (now reinstall) Etoys that Ubuntu provides? Assuming the first question can be answered of course.
> Yours in curiosity and service, --Jerome Peace 

You didn't say if Etoys-To-Go worked on your machine, but I'll assume it did.

That npetoys.so is included in Etoys-To-Go is an accident. Etoys-To-Go is not meant to be used as a browser plugin.

However, since the plugin is there, it might be possible to use it. Try this:

First, rename to "Etoys.app" and put it in your home directory:

	mv "Etoys-To-Go 4.app" ~/Etoys.app

Replace /usr/share/Etoys.app by $HOME/Etoys.app:

	sed -i.bak 's-/usr/share-$HOME-' ~/Etoys.app/Contents/Linux-i686/npetoysrun

Link the script to one directory the plugin looks for it:

	mkdir ~/.npsqueak
	ln -s ~/Etoys.app/Contents/Linux-i686/npetoysrun ~/.npsqueak/

Finally, link the plugin to one directory the browser looks for it:

	mkdir -p ~/.mozilla/plugins/
	ln -s ~/Etoys.app/Contents/Linux-i686/npetoys.so ~/.mozilla/plugins/

I'm attaching the most current plugin README from the sources ...

- Bert -

-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname   : README.npsqueak
Dateityp    : application/octet-stream
Dateigröße  : 5301 bytes
Beschreibung: nicht verfügbar
URL         : http://lists.squeakland.org/pipermail/etoys-dev/attachments/20100512/2a24fdd1/README.obj
-------------- nächster Teil --------------

More information about the etoys-dev mailing list