[etoys-dev] Updating from server error

Bert Freudenberg bert at freudenbergs.de
Thu May 6 01:00:19 EDT 2010

On 05.05.2010, at 20:41, Ricardo Moran wrote:
> Hi, I was trying to update my dev image and it throw me some errors I couldn't resolve. I have my own modified dev image, so I thought my image has something incompatible... I don't know. 

Did your dev image start out with the etoys 4.0 dev image? Or how did you make it?

> Then I tried using a dev image downloaded from here: http://etoys.squeak.org/download/Etoys-Dev-4.1.2369.zip and it throw me an error when loading:

I just tried that again.  Worked fine for me, no error at all.

> >>> Etoys-bf.3 <<<
> - remove unused EToySystem class
> The method with trouble was Flaps class>>#unregisteredQuadsWithReceiver:. It fails with #errorKeyNotFound so I modified the method.
> unregisterQuadsWithReceiver: aReceiver 
> 	"delete all quads with receiver aReceiver."
> 	self registeredFlapsQuads
> 		do: [:assoc | assoc value
> 				removeAllSuchThat: [:q | (self environment at: (q first) ifAbsent:[Transcript show: q first; cr. nil]) = aReceiver ]]
> I simply added the "ifAbsent: [...]" part to print the troubling keys and avoid the error. As a result the update finished ok but now I want to know if my image is healthy. FYI the keys printed were:
> SelectorBrowserprototypicalToolWindow "WTF??"
> Scamper
> Celeste
> Anyway, this might not be important (or you may already know it) but I felt like telling you.
> Best regards,
> Richo

Hmm, anybody else seeing this problem?

I tried to find the offending keys:

	Flaps registeredFlapsQuads associations
		collect: [:assoc | assoc key -> (assoc value
				reject: [:q | Smalltalk includesKey: q first ])]

For me this is empty ...

> P.S.: I just realized you uploaded a newer image to http://etoys.squeak.org/download/. So I guess I just simply download that one :)

Yes, I was about to report on that :) Besides being updated, this now includes a thumbnail to jump to the home project.

And the home project does work again, as you might have seen I modified the Player recompiling so the script references are compiled in the proper world. Maybe someone should comment on that ... seems to work though :)

The dual changeset update stream / Monticello repository updates seem to work quite well. E.g., the 2373fixHome-bf.cs changeset relies on the updated Player compile methods, and 2374discardTranslations-bf.cs on a method for discarding the translations. So I posted the update.2-bf.mcm configuration to the update stream as 2372repo1080-bf.cs. This ensures that certain package versions are loaded.

I hope that's a good way to split the responsibilities - put code changes into Monticello, and do-its into the update stream ... best of both worlds :)

The "repository version" refers to the sum of package version in the loaded configuration. Etoys' SystemVersion now reports both, the highest update number and the repo version + date:

	etoys4.1 of 29 April 2010 update 2374 (repo v1082 of 4 May 2010)

Here is a page to easily see the update stream:


- Bert -

More information about the etoys-dev mailing list