[etoys-dev] Re: Etoys new fonts

Bert Freudenberg bert at freudenbergs.de
Sat Jun 12 08:28:57 EDT 2010

On 12.06.2010, at 10:09, K. K. Subramaniam wrote:

> On Saturday 12 Jun 2010 1:42:04 am Bert Freudenberg wrote:
>> I was simply suggesting that for
>> better clarity we use "resource directory" in the code, rather than "image
>> directory".
> +1 and introduce userRepository or toysRepository instead of defaultDirectory. 
> The current names are misleading.

I do not think this would add clarity. By default, stuff goes to the default directory. Seems clear enough to me.

>> A lot of code assumes (rightly) that the default directory is writable.
>> When the security sandbox is enabled, we only have a single writable
>> directory.
> why only one directory (writable+persistent)?


> When I wrote LatexMorph, I also 
> needed writable+volatile for converting LaTeX code to images quickly on the 
> fly. I didn't want persistent directory because of higher i/o latencies, power 
> drain and/or wear-n-tear risks. Do you see any increased security issues with 
> two repos?
> I expect similar situations in code involving dynamic font operations, 
> multimedia codec or inter-process communications. Anyone?

We would have to change the SecurityPlugin on all platforms. I see little benefit to Etoys, but hypothetically, which directories would you like this "volatile" directory to be, on each of our supported platforms?

- Bert -

More information about the etoys-dev mailing list