[etoys-dev] Re: Etoys new fonts

K. K. Subramaniam kksubbu.ml at gmail.com
Sat Jun 12 04:09:25 EDT 2010

On Saturday 12 Jun 2010 1:42:04 am Bert Freudenberg wrote:
>I was simply suggesting that for
> better clarity we use "resource directory" in the code, rather than "image
> directory".
+1 and introduce userRepository or toysRepository instead of defaultDirectory. 
The current names are misleading.
> Right, except for loading fonts. Those need to be looked up in the resource
> directory for the fonts we ship, and possibly also in the default
> directory for user-installed fonts (but I'd hope that in normal operation
> we do not need that font download anymore).
fonts are just one type of such resource. I could think of images, audio, 
video clips (referenced in guides for instance). Not all audio clips need to 
loaded into an image (e.g. cultural variations of meow sounds for instance).

> A lot of code assumes (rightly) that the default directory is writable.
> When the security sandbox is enabled, we only have a single writable
> directory.
why only one directory (writable+persistent)? When I wrote LatexMorph, I also 
needed writable+volatile for converting LaTeX code to images quickly on the 
fly. I didn't want persistent directory because of higher i/o latencies, power 
drain and/or wear-n-tear risks. Do you see any increased security issues with 
two repos?

I expect similar situations in code involving dynamic font operations, 
multimedia codec or inter-process communications. Anyone?


More information about the etoys-dev mailing list