[etoys-dev] FFI on Etoys dev image

Bert Freudenberg bert at freudenbergs.de
Tue Jul 6 18:30:01 EDT 2010

On 06.07.2010, at 16:07, Lawson English wrote:

> On 7/2/10 7:23 PM, Bert Freudenberg wrote:
>> On 02.07.2010, at 16:11, Ricardo Moran wrote:
>>> Hi guys, I've been trying to install FFI in the latest dev image and I ran into troubles. None of the FFI versions I found seemed to work. I tried the latest one from http://source.squeakfoundation.org and the two versions I found on the SqueakMap website.
>>> It fails to perform "Win32Shell>>shellExecute:lpOperation:lpFile:lpParameters:lpDirectory:nShowCmd:". But it doesn't seem to be a problem with FFI because I tried the same versions in other images and it works. I don't know what needs to be fixed. Do you have any idea?
>> Well Etoys doesn't really need to support FFI. But what error do you get?
>> - Bert -
> an etoys extension that exposed bits of OpenGL would need it, as a for instance...

No. If we wanted 3D we would use the Balloon3D plugin. Or we would write an OpenGL plugin. Not FFI, which is inherently unsafe.

- Bert -

More information about the etoys-dev mailing list