[etoys-dev] FFI on Etoys dev image

Ricardo Moran richi.moran at gmail.com
Sun Jul 4 20:02:32 EDT 2010

I know Etoys doesn't need FFI, but I wanted to use the latest image for
Physical Etoys. I didn't want to bother, but I don't know how to fix this.

The error I get is: "A call to an external function failed". I had to add a
"self externalCallFailed" to get this error. I hope this helps.


On Fri, Jul 2, 2010 at 11:23 PM, Bert Freudenberg <bert at freudenbergs.de>wrote:

> On 02.07.2010, at 16:11, Ricardo Moran wrote:
> > Hi guys, I've been trying to install FFI in the latest dev image and I
> ran into troubles. None of the FFI versions I found seemed to work. I tried
> the latest one from http://source.squeakfoundation.org and the two
> versions I found on the SqueakMap website.
> > It fails to perform
> "Win32Shell>>shellExecute:lpOperation:lpFile:lpParameters:lpDirectory:nShowCmd:".
> But it doesn't seem to be a problem with FFI because I tried the same
> versions in other images and it works. I don't know what needs to be fixed.
> Do you have any idea?
> Well Etoys doesn't really need to support FFI. But what error do you get?
> - Bert -
> _______________________________________________
> etoys-dev mailing list
> etoys-dev at squeakland.org
> http://lists.squeakland.org/mailman/listinfo/etoys-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakland.org/pipermail/etoys-dev/attachments/20100704/77eb7669/attachment.html

More information about the etoys-dev mailing list