[etoys-dev] Preparing for Monticello-based updates

Bert Freudenberg bert at freudenbergs.de
Tue Apr 27 07:30:51 EDT 2010

On 27.04.2010, at 05:57, Andreas Raab wrote:
> * Scaling. As much as I understand the desire, is there a way to turn off display scaling and the uber-large cursors? The fonts are simply too hard on my eyes for continuous work.

That's exactly why I would like developers to use the same settings as users. If it's unbearable for us, how can we expect our users to tolerate it?

> * Image saving. At first I tried a "save as" but this complained about not finding the sources/changes file afterwards. How come? Second, saving the image produces a visible flashing which is for some reason completely discomforting - it looks as if there was an error that the system tried to inform me about by the flash.

The flashing comes from using the virtual screen. The display is black at first, then the virtual screen is drawn. It is distracting, yes. Yoshiki tried to reduce it before, but it's still not fully gone, just less pronounced.

The save-as issue I explained before:

Begin forwarded message:
> From: Bert Freudenberg <bert at freudenbergs.de>
> Date: 21. April 2010 11:09:28 MESZ
> To: etoys-dev dev <etoys-dev at squeakland.org>
> Subject: Re: [etoys-dev] Preparing for Monticello-based updates
> On 21.04.2010, at 05:20, K. K. Subramaniam wrote:
>> On Monday 19 April 2010 05:22:14 pm Bert Freudenberg wrote:
>>> Download Etoys-To-Go4-Final.zip from squeakland.org and unzip and run
>>> * get halo for world, choose "preferences..." from halo menu
>>> * disable "eToyFriendly" in the "scripting category"
>>> * click the gray World background, choose "previous project" from the World
>>> menu
>>> * you'll be taken to the hidden top-level project, light-blue
>>> background
>>> now is a good time to save the image
>> Linux users will get an error about missing sources file when trying to save 
>> the image under a new name.
> Well, my instructions said "save" not "save as" ;)
> Etoys hard-codes the image name anyway, working with several images is not supported without fiddling. The error is not even Linux-specific, you get the same error on the Mac.
> Save replaces the image where it was. Save-as stores into the default directory, even if you do not change the image name. In Etoys, the default directory usually differs from the image directory, unlike regular Squeak. The image directory usually is read-only (that's why I recommended Etoys-To-Go where it is writable).
> Because of this, save-as will not store the image where it was originally (inside Etoys-To-Go.app in this case), but into the "user directory". That is the "Etoys" folder next to "Etoys-To-Go.app". But running Etoys-To-Go again will not use that saved image but still the original one. Running a copy of the image outside the Resources folder will not work either, as translations and examples etc. are looked up relative to the image.
>> It looks for sources file in Contents/Linux-i686 
>> while the sources file is in Contents/Resources. Workaround is to link the file 
>> into the vmPath.
> Well, that makes the error go away, but as I explained above, will not result in a fully functional Etoys.
> If you really wanted to support out-of-place images, you would have to change the logic for both the source file lookup and resources lookup. There has been no need for that so far, but we'd happily take (reasonable) patches :)

- Bert -

More information about the etoys-dev mailing list