[etoys-dev] Installing Etoys and Squeak on Ubuntu 9.04

Ricardo Moran richi.moran at gmail.com
Mon Aug 3 15:17:54 EDT 2009

Hi, I'm starting to work on Linux, I installed Ubuntu 9.04 and I was trying
to install Etoys and Squeak. I should tell you: I am a Windows user with no
experience in Linux.
I downloaded the EtoysInstaller.deb from squeakland and it worked fine. Then
I tried to install squeak following the instructions I found in
http://wiki.squeak.org/squeak/3616. This also worked, I typed squeak in the
terminal and Squeak opened.
Then I tried to use one of my own images in which I usually work (on
Windows), so I opened it using the command "squeakvm". The image worked
almost fine, the only problem I found was that the buttons on the "Sugar
Navigator Flap" wasn't displayed correctly.
Then I tried to open Etoys using the menu "Applications->Education->eToys"
but it didn't open anymore. I went to /usr/share/etoys and tried to open the
etoys.image with squeakvm and it opened with an error: "A primitive has
failed" and the display all wrong (I had to redraw the screen by clicking on
"display mode->scale to fit").
I tried reinstalling Etoys but the Package Installer tells me that "A later
version is already installed". I suppose the Etoys image needs a different
vm but I don't know where to find it.
What do you think I should do?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://luna.immuexa.com/pipermail/etoys-dev/attachments/20090803/75a87213/attachment.html

More information about the etoys-dev mailing list